It's all about the answers!

Ask a question

Hidden field in 'Kind' dropdown in editor's presentation??


Swapnil Khandelwal (136) | asked Apr 08 '13, 8:33 a.m.
edited Apr 08 '13, 8:36 a.m.

In editor's presentation, while adding a presentation, whenever we add any attribute(of any datatype), in 'Kind' dropdown, what is the function of 'Hidden' option??

I've tried it but it works same as other options i.e. the field isnt hidden even after selecting 'Hidden'... 

3 answers



permanent link
Elisabeth Carbone (61698) | answered Apr 09 '13, 4:05 a.m.
JAZZ DEVELOPER

Hello Swapnil,
as Eric has pointed out there are defects about hidden.

I did a quick test, boith server and RTC eclipse client are on 3.0.1

 In the eclipse client, I select the presentation for defects and set the Kind Hidden for the attribute Type.
Save the Project Area.
Run a query that returns all defects.
Right-clikc in the first column where the icon for defects is visible.
On the popup menu I select Syncronize Attributes

The attribute type is not visible after that in the RTC eclilpse client and when I empty the cache in Internet Explorer the attribute is not visible there either. Have not tested other browsers.

/Elisabeth


Comments
Swapnil Khandelwal commented Apr 09 '13, 8:01 a.m.

Hi Elisabeth,

I have tried the same thing that you have mentioned but still no luck...


permanent link
Elisabeth Carbone (61698) | answered Apr 08 '13, 9:04 a.m.
JAZZ DEVELOPER

Hello,

if you select Hidden as the Kind of the attribute, the attribute should not show up anymore when viewing instances of that wi type.

For existing WI of the type you change the presentation for you may have to run Syncronize Attributes and eventually you have to clean the browser cache.

Hope it helps.

Elisabeth


Comments
Swapnil Khandelwal commented Apr 09 '13, 12:23 a.m.

Hi,

I have selected kind as hidden, but still i cant see any difference...I am still able  to see that attribute at front/web end...and where is Syncronize Attributes option??


permanent link
Eric Jodet (6.3k599120) | answered Apr 08 '13, 8:54 a.m.
JAZZ DEVELOPER
 Hello,
which version of RTC are you using.
My 4.0.2 Eclipse client shows a couple of "flavors" for the hidden feature:

Thanks.
Eric.

Comments
Swapnil Khandelwal commented Apr 09 '13, 12:16 a.m.

Hi Eric,

I am using RTC 3.0.1


Eric Jodet commented Apr 09 '13, 1:39 a.m.
JAZZ DEVELOPER

 Hello,

searching jazz.net, I found issues like:
and

You may want to evaluate using RTC 4.0.1 or 4.0.2

Thanks
Eric.

Your answer


Register or to post your answer.