It's all about the answers!

Ask a question

Disabling HTTP Referer header breaks RQM web interface

Anthony Howe (133) | asked Mar 11 '13, 4:12 p.m.
In Firefox I disable "network.http.sendRefererHeader" for privacy reasons to hinder advertiser site tracking. However I discovered with recent upgrade to RQM 4.0.1 that you can't save test scripts, cases, etc. nor even logout.

One answer

permanent link
Gerd Schiering (12211316) | answered Mar 21 '13, 7:20 a.m.
Hi Anthony,

After a quick glance with Firebug we use the referring to make sure that sessions and users are taken care of between the different CLM applications (RQM, RRC, JTS, RTC).
I did not find any RQM calls to advertising sites though.

If you don't want to switch back and forth between enabling and disabling that setting in FF,
can I suggest to use "private browsing" for your personal browsing and keep using the "default" browsing for all RQM related work?

Gerd Schiering
IBM Rational

Anthony Howe commented Mar 21 '13, 4:11 p.m.

That would not work for two reasons:

1. network.http.sendRefererHeader is a browser wide setting so would apply equally in general and private browsing.

2. Separating my web usage on my personal equipment (BYOD office) based on work or personal activity is a non-starter.

My issue is not that RQM participates in advertising/tracking sites, but that because I disable the HTTP Referer: header for personal security on my equipment, I can no longer use RQM, because the application is using the Referer in some capacity, probably to get a base URL since there is no session info encoded in the URLs (session info is passed by cookies).

Gerd Schiering commented Mar 22 '13, 5:24 a.m.

Hi Anthony,
Thanks for clarifying.
So you cannot seperate personal and business on the one FireFox.
As a workaround you could use "FireFox portable" in addition to the local FireFox you already have.
This way you can have one FF executable and disable theĀ  network.http.sendRefererHeader setting to use for personal browsing and the other leaving that option enabled so that you can use RQM properly. Does that work for you?

Gerd Schiering
IBM Rational

Your answer

Register or to post your answer.