It's all about the answers!

Ask a question

Any RQM/Jenkins integration materials?

lin liang (1123) | asked Feb 20 '13, 2:32 a.m.
I heard Rational DevOps was working on RQM/Jenkins integration.
Is there any place I can get more materials? I  want to know the architecture of the integration, what has been implemented  and how to integrate into jenkins environment

14 answers

permanent link
Ricky Jay (28626) | answered May 16 '16, 12:40 p.m.

Java was installed and configured correctly. Problem seems to be on Jenkins end as i have run the same script on CMD and it start executing my test cases.

I have restarted the Jenkins service as well and tried again through Jenkins but it still failed with the same error. where as the script works fine on command line.

any guess?

sam detweiler commented May 16 '16, 12:59 p.m.

remember that jenkins does NOT pass the system environment variables to the started tasks.. you must add java to the toolset in jenkins and add it to the path and env variables to be used...

Ricky Jay commented May 16 '16, 1:02 p.m.

Hi Sam,

can you mention where it should be set in the jenkins? I dont see any option in "Manage Jenkins" page to add java and environment variables.

permanent link
Ricky Jay (28626) | answered May 16 '16, 1:28 p.m.
Getting different error now,

Error: Unable to access jarfile RQMExecutionTool.jar

C:\Program Files (x86)\Jenkins\workspace\Test4_RPT>exit 1
Build step 'Execute Windows batch command' marked build as failure
Finished: FAILURE

permanent link
Oskar Berreteaga (3315) | answered May 17 '16, 5:28 a.m.
You mentioned you can run it from the command line. Could it be a permissions issue? Are you using the same user from Jenkins and the command line?

permanent link
Ricky Jay (28626) | answered May 17 '16, 6:19 a.m.

Finally it is setup to run automated test cases through Jenkins. What i did is,

Create a batch file with my command line script and placed it in RQMExecutionTool folder.
In Jenkins, referred below.
cd C:\RQMExecutionTool
Execute1 (Bat file name)

I dont know why it wasn't picking the commands directly from Jenkins item but the above worked.

Thank you so much for your help. It really worked for me. :)

Your answer

Register or to post your answer.