It's all about the answers!

Ask a question

Upgrade to CLM


Abhijith Rao (171912) | asked Feb 12 '13, 4:36 a.m.
retagged Feb 12 '13, 5:26 p.m. by Douglas Bush (28125)

Currently we have RQM version 2.0.1.1 ifix2 in one server and no other tools of Jazz. We are planning to migrate RQM to version 4.0.1. Also we would like to install RTC and RRC as well in this one server and make it a CLM. Can you provide the best solution for acheiving this. If you can provide information in step wise with links if required, it would be helpful

3 answers



permanent link
Rajat Singh (59833545) | answered Feb 12 '13, 8:07 a.m.
edited Feb 12 '13, 8:07 a.m.
 Please refer to the product help: http://pic.dhe.ibm.com/infocenter/clmhelp/v4r0m1/topic/com.ibm.jazz.install.doc/topics/c_upgrade_overview.html. 

Run the interactive upgrade guide: http://pic.dhe.ibm.com/infocenter/clmhelp/v4r0m1/topic/com.ibm.jazz.install.doc/topics/roadmap_clm_upgrade.html . 

To go from 2.x to 4.x please note: 

Upgrading from V2 to V4: Upgrading from version 2 to version 4 is a two-step process. You must first upgrade your server to the latest fix pack of version 3.0.1, then upgrade to version 4.0.1. 



permanent link
Jim Ruehlin (79114) | answered Feb 12 '13, 2:13 p.m.
JAZZ DEVELOPER
Upgrading from 2.x to 3.x is very detailed and complex. You should look at the CLM 2011 Upgrade Reference and the CLM 2011 Upgrade Workshop. The Reference provides a lot of resources for upgrade planning. The Workshop takes you through a scenario of upgrading all the CLM products. The CLM 2011 Upgrade FAQ is also very helpful.

Give yourself plenty of time to upgrade to 3.x. You're just upgrading RQM, but I'd plan on a minimum of:
1 full day for research and planning.
1 full day to perform the actual upgrade.
1-2 days to validate the upgrade.

Your mileage may vary depending on the size of your RQM database, and if you use reporting. As I recall, the export/import benchmarks for the 3.x upgrade of RQM are very slow.

You can just focus on RQM at first. Get that upgraded to 3.x then 4.x. Then install RTC/RRC 4.x. For both the 3.x and 4.x upgrades, the Interactive Upgrade guides in the Infocenter for each release is very helpful.

Comments
Abhijith Rao commented Feb 14 '13, 12:07 a.m.

Can I uninstall RQM v2 and install v3 or v4 directly? Is this recommended? RQM v2 is not being used much. If this method is possible, can I take the same SQL database for RQM v3 or v4 or should I need a new database?


Jim Ruehlin commented Feb 14 '13, 9:56 a.m.
JAZZ DEVELOPER

If you are willing to abandon all your current data and start fresh, then you can remove your current installation and install 4.x. Better yet, leave your current installation intact for historical purposes, and install CLM 4.x. Starting with a fresh installation of 4.x is MUCH easier than upgrading, so if you don't need your existing data it's a good alternative.

You will need a new public URI if you are going to maintain 2 versions of CLM. If you get rid of your current CLM installation, you can re-use that public URI.

If you are removing your current CLM installation, I would also delete the database and create new ones. The InfoCenter instructions will tell you how to create the new DB. Jazz setup will create the DB if you are using Derby.


permanent link
jason green (1463) | answered Feb 12 '13, 5:52 p.m.
JAZZ DEVELOPER
 I wholeheartedly agree with Jim's answer. As for preparation, please note we have several videos on YouTube regarding CLM, installation and preparation:  http://www.youtube.com/playlist?list=PL3D4EC6A5D5ECC989

Your answer


Register or to post your answer.