It's all about the answers!

Ask a question

Why Can't I Create a Build using the Jetty RTC Server?


Andrew Soloninka (5511924) | asked Jan 28 '13, 2:36 p.m.
edited Jan 28 '13, 2:39 p.m.
 I can't save a newly created zOS based Build Definition when I'm using the Jetty RTC Server. I don't have this problem when using the RTC server running on Tomcat. 

My RTC Eclipse Client throughs the following exception:
com.ibm.team.repository.common.transport.ServiceNotAvailableException: CRJAZ0106I The server is temporarily unavailable, the request for the URL "/jazz/service/com.ibm.team.enterprise.systemdefinition.common.ISystemDefinitionService" was denied. Please retry again later, or if the error persists, contact your server administrator.

Just before this exception occured the following exception occured on the Jetty RTC Server:
WARN com.ibm.team.repository - Exception thrown when resolving package descriptor for package "org.eclipse.emf.ecore.plugin.RegistryReader$EPackageDescriptor@6e1c6e1c": java.lang.ClassNotFoundException: com.ibm.team.repository.internal.tests.componentversion.ComponentversionPackage2

Please note that I was able to create and save packages and deployments. 

Comments
Andrew Soloninka commented Jan 29 '13, 6:30 p.m.

More information:


The above exception occurs in the NewBuildDefinitionWizard, specifically the openBuildDefinition method. Packages and Deployments both use the same code and they work fine 

Accepted answer


permanent link
Robin Bobbitt (58659) | answered Feb 07 '13, 4:13 p.m.
Hi Andrew,

I tried setting this environment up from scratch and was able to launch an eclipse client and a Jetty server and save a new data set definition. I did the following:

1. Follow lab 1 of the Rational Team Concert 4.0 Extensions Workshop. I used trial Enterprise Developer licenses instead of the 10 free developer licenses.
2. Launch an eclipse client and Jetty server and confirm that there are no EE features in the client, as expected (e.g., no Enterprise Extensions node in the Team Artifacts view).
3. Add my RTC client (C:\RTC40Dev\installs\TeamConcert\jazz\client\eclipse) to the target platform, since the EE features are not in the RTC SDK. Now my Target Platform includes the RTC SDK and the RTC Eclipse client.
4. Launch my eclipse client again and confirm that the Enterprise Extensions node now appears, but I can't save a Data Set Definition because, as expected, none of the enterprise services are in the Jetty server (indicated by request for ISystemDefinitionServcie denied message).
5. Add the enterprise update site (file:/C:/RTC40Dev/installs/JazzTeamServer/server/conf/ccm/sites/enterprise-update-site/) as a Software Site to the Target Platform. Uncheck "Include required software". Now my Target Platform includes the RTC SDK, the RTC Eclipse client, and the Enterprise Update Site from my server.
6. Re-launch the Jetty server and eclipse client. When launching the Jetty server, choose to add a feature and type in com.ibm.team.enterprise.server.feature. Now I can create a data set definition.

Note that I did NOT have to import the enterprise server feature to my workspace.
Andrew Soloninka selected this answer as the correct answer

Comments
Andrew Soloninka commented Feb 07 '13, 6:57 p.m.

Thanks Robin, I used the software site instead of the Installation for the(file:/C:/RTC40Dev/installs/JazzTeamServer/server/conf/ccm/sites/enterprise-update-site/) and added it to the Target Platform  . It works fine now 

2 other answers



permanent link
Robin Bobbitt (58659) | answered Jan 30 '13, 4:22 p.m.
edited Jan 30 '13, 4:22 p.m.
It's been a while since I've used the Jetty server, but have you confirmed that you're including the enterprise extensions plugins in your launch?
One thing you can check... Go to https://your_host:9443/ccm/admin?internal=true
You will see an "Internal Tools" menu in the left hand navigator. Click on "Component Status" and look for the com.ibm.team.enterprise.systemDefinition entry. You need a
com.ibm.team.enterprise.systemdefinition.common.ISystemDefinitionService entry underneath it with a green check mark.
Another thing to check is the "Provision Status." You should see several bundles being installed that start with com.ibm.team.enterprise.systemdefinition, including
com.ibm.team.enterprise.systemdefinition.common. You should also see that bundle being started.

Comments
Andrew Soloninka commented Jan 30 '13, 10:46 p.m. | edited Jan 30 '13, 10:47 p.m.

Robin, I used the URL above and checked the Internal Tools on both my Jetty Server and my Tomcat installations. I found that the Tomcat  installation had a whole group of Enterprise services and the Jetty installation had none. I'm going to experiment with adding Enterprise features to my Jetty installation and see what happens. 


Andrew Soloninka commented Jan 31 '13, 4:00 p.m.

Robin, All of the Enterprise Components  except two now appear on the Jetty Server. These 2 are: 


com.ibm.team.enterprise.cleanup
com.ibm.team.enterprise.zos.systemdefinition.migration

However, none of the services of the new Enterprise components are registered. How do I register them.


 


Andrew Soloninka commented Feb 04 '13, 1:35 p.m.

Robin, I have been trying to get the  Jetty Server running properly since adding the Enterprise Components.


I have researched how to register the Enterprise Components in the forum and have not found any information.

Also, I cannot get the server to start cleanly, getting the following exceptions:

java.lang.IllegalStateException: Workbench has not been created yet.

org.osgi.service.component.ComponentException: Exception occurred while creating new instance of component

java.lang.ClassCircularityError 

For each component, I added a client feature and a common feature. Is adding the Client feature correct?



Robin Bobbitt commented Feb 05 '13, 12:11 p.m.

Andrew, no, you would want to be including the server features. The primary enterprise server feature is called com.ibm.team.enterprise.server.feature. Take a look at your server install in the server\conf\ccm\sites\enterprise-update-site directory. This will give you an idea of the features and plugins your Jetty server needs to pick up.


Andrew Soloninka commented Feb 05 '13, 4:39 p.m. | edited Feb 05 '13, 4:39 p.m.

When I go to add com.ibm.team.enterprise.server.feature to my Debug Configuration for the Jetty Server, It does not show up in the Add Feature Window.  


Robin Bobbitt commented Feb 05 '13, 4:52 p.m.

Verify that the enterprise features and plugins are included in your target platform. If your target platform only points at the RTC SDK and/or the RTC eclipse client, you won't have the enterprise server features and plugins available.


Andrew Soloninka commented Feb 06 '13, 10:55 a.m.

I found that I only had the RTC SDK and RTC eclipse client. I then added the Enterprise Update Site from the Jazz Team Server installation. This brought in almost all of the Enterprise Features and Plugins. The one exception was the com.ibm.team.enterprise.server.feature feature. Why would this happen?


Andrew Soloninka commented Feb 06 '13, 12:47 p.m.

I tried pulling the com.ibm.team.enterprise.server.feature feature out of the installation dir and putting it in my workspace. I started the server and it initially came up clean. However, when I started the RTC Client I got several errors including:


1. Component has not been installed in the database for several components
2. com.ibm.team.repository.common.transport.TeamServiceRegistryException 

for the Jetty Server


showing 5 of 8 show 3 more comments

permanent link
Robin Bobbitt (58659) | answered Jan 29 '13, 11:36 p.m.
Are you able to create/view/modify system definitions using the Jetty server?

Comments
Andrew Soloninka commented Jan 30 '13, 12:30 p.m.

Robin, where do I find the system definitions? 


Robin Bobbitt commented Jan 30 '13, 1:16 p.m.

In the Team Artifacts view, expand your project area > Enterprise Extensions > System Definitions > z/OS. You should be able to create/view/modify some data set definitions, translators, and language definitions here.


Andrew Soloninka commented Jan 30 '13, 3:37 p.m.

Robin, I tried creating the following under System Definitions:

  • New Data Set Definition
  • New Language Definition
  • Edit System Definitions Mappings
and got the following error:

CRJAZ0106I The server is temporarily unavailable, the request for the URL "/jazz/service/com.ibm.team.enterprise.systemdefinition.common.ISystemDefinitionService" was denied. Please retry again later, or if the error persists, contact your server administrator.

 

Your answer


Register or to post your answer.