It's all about the answers!

Ask a question

Report Data Collection Job Status Failed

Silvio Brandani (1111) | asked Jan 28 '13, 8:36 a.m.
Hi all,

we get following error running  Data Collection Job "Common" , instead "Star" job succeded

2013-01-16 17:16:36,698 [         http-bio-9443-exec-65] ERROR ervice.internal.common.CommonRemoteSnapshotService  - CRRRE1417E: The HTTP status '401' and the message is 'Unauthorized'.
java.sql.SQLException: CRRRE1417E: The HTTP status '401' and the message is 'Unauthorized'.

5 answers

permanent link
Jhon Valderrama (3158) | answered Mar 22 '13, 11:45 a.m.
Silvio, how are you?, can you solved this problem, i have the same problem with Repository job

permanent link
Silvio Brandani (1111) | answered Jan 31 '13, 9:15 a.m.
the user (called etl_user) have the licences 'Data Collector' assigned .

permanent link
Jackie Albert (1.6k14947) | answered Jan 30 '13, 3:26 p.m.
Along with checking the password, also ensure that the ID set to run the data collection jobs has the 'Data Collector' license assigned to it.

permanent link
Rajat Singh (59833545) | answered Jan 28 '13, 8:59 a.m.
Could you check if the password entered to run the 'Common' datawarehouse job is correct.
Try re-entering the password and run the jobs again.

Best Regards

Silvio Brandani commented Jan 31 '13, 9:14 a.m.

The password is correct, other jobs works fine just the Common failed

permanent link
Don Yang (7.7k21114139) | answered Mar 25 '13, 2:34 a.m.
The general check points for failed ETL will be:
dw collection job user's password, license assigned or not, whether it has jazzadmin permission(from jts/admin > user page to check with the etl user and make sure it has right license and JazzAdmin permission.
Some of them are covered above.
From the original statement "we get following error running  Data Collection Job "Common" , instead "Star" job succeded", we know Common failed but Star worked. Since Star does not require an user and password, it is worth to try to re-enter the password of common job and try to run the job again and see if it works(to verify if the etl user and password are right, you can use the same user and password and login to the jts/admin page, you should be able to login to the page properly).

Another check point(rare) is under jts/admin > Data Warehouse Connection,
check with XDC Authentication Type and see if you use default "Form" or not.
If it was set to "JTS" which required consumer key and consumer secret instead of
username/password, you can go to jts/admin > data collection job page and see if the
username/password are used which is not correct.
We have seen some issue when using JTS as authentication type in 3.0.1.x and you can try to change the type to Form and then use the right etl job user and password in data collection job to fix the issue.

Hopefully these help.

Your answer

Register or to post your answer.

Dashboards and work items are no longer publicly available, so some links may be invalid. We now provide similar information through other means. Learn more here.