It's all about the answers!

Ask a question

Form based authentication issue using Firefox REST Client

Alexander Schinko (35511812) | asked Jan 25 '13, 10:55 a.m.

I tried to follow the steps in the OSLC Workshop however I don't not get properly authenticated at my server using the REST Client plugin.

If I try to get the rootservices catalogue it seems to work fine, however if I try to get any anyother service I get "authrequired" and a html body with content "Loading..." . The header looks like this:
  1. Status Code: 200 OK
  2. Cache-Control: private
  3. Content-Encoding: gzip
  4. Content-Length: 1174
  5. Content-Type: text/html;charset=UTF-8 ==> should be "rdf"
  6. Date: Fri, 25 Jan 2013 15:42:53 GMT
  7. Expires: Thu, 01 Jan 1970 01:00:00 CET
  8. Server: Apache-Coyote/1.1
  9. Set-Cookie: JSESSIONID=8241D10F956FCD1F85A00DA3F997FBE8; Path=/jazz; Secure JazzFormAuth=Form; Path=/jazz
  10. X-com-ibm-team-repository-web-auth-msg: authrequired
 I'm logged in properly, therefore there seems to be some problems with the form based FF10 and Rest Client Addon 2.0.4 on CLM 3.0.1.

Does anyone know a work arround?

2 answers

permanent link
Alexander Schinko (35511812) | answered Feb 13 '13, 9:40 a.m.
edited Feb 13 '13, 9:43 a.m.
Indeed the 3rd party cookies were disabled. After enabling it worked.

permanent link
Vladimir Zahariev (1503) | answered Jan 25 '13, 11:08 a.m.
Please try first accessing the URL in the browser, and authenticate, then open the REST Client and it should work fine.


Alexander Schinko commented Jan 25 '13, 11:44 a.m. | edited Feb 05 '13, 8:49 p.m.

Hello Marc,

this is exactly what I have tried. Do I maybe have something wrong with my FF settings?


Your answer

Register or to post your answer.

Dashboards and work items are no longer publicly available, so some links may be invalid. We now provide similar information through other means. Learn more here.