It's all about the answers!

Ask a question

adaptor JazzJBE not found


Steffen Kriese (381721) | asked Jan 24 '13, 8:57 a.m.

Hello,

I was trying to connect RTC 4.0.0.1 and Build Forge 7.1.3.0 as described here:

https://www.ibm.com/developerworks/mydeveloperworks/blogs/tfeeney/entry/using_the_team_concert_build_forge_integration_to_build_the_money_that_matters_sample_app?lang=en

The checkout from RTC fails. The last lines from the log file look like this:

Adaptor using env name 'RTC checkout' for macro [ADAPTOR].

Interface Processor Loaded.

Parsing Adaptor XML.

Loading source adaptor JazzJBE

The adaptor could not be found.

Any idea how I can help Build Forge to find the missing adaptor?


Kind regards

Steffen

2 answers



permanent link
Steffen Kriese (381721) | answered Feb 08 '13, 2:08 a.m.

The adaptor xml files are located in the ../Platform/interface directory. Among some other files there are a JazzJBE.xml and a JazzSCM.xml. If a build step with .source JazzJBE gets executed BF returns an error complaining the adaptor can't be found. When changing the step to .source JazzSCM the content of the JazzSCM.xml is listed in the log file and BF starts to process the adaptor. Coping the content of JazzJBE.xml to JazzSCMxx.xml allows to run the adapor and to do the checkout from RTC. It looks like there is some kind of filter which allows JazzSCM*.xml but not JazzJBE*xml.
Not sure this is a bug or a feature.

Regards, Steffen


permanent link
Spencer Murata (2.3k115870) | answered Feb 07 '13, 12:06 p.m.
FORUM MODERATOR / JAZZ DEVELOPER
 You can try the option  Reset Adaptor Templates from the Build Forge Administration menu.  That will force Build Forge to reload the Adaptor Template xml files under [BF dir]/interface.  That should make sure that the adaptors are properly loaded.

~Spencer

Your answer


Register or to post your answer.