Rational Reporting for Development Intelligence 2.0.6

Product Release / Trial | February 28, 2014
This is not the most recent version.Rational Reporting for Development Intelligence 1.0.2.1 is required for use with CLM v3.0.1x.
Rational Reporting for Development Intelligence 2.0.5 is required for use with CLM v4.0.5x.
Rational Reporting for Development Intelligence 2.0.6 is required for use with CLM v4.0.6x.
Rational Reporting for Development Intelligence 5.0.2 is required for use with CLM v5.0x.

Rational Reporting for Development Intelligence 2.0.6 Release Notes

Rational Reporting for Development Intelligence 2.0.6 Release Notes

The Version 2.0.6 release of Rational Reporting for Development Intelligence contains new features and fixes for defects and APARs. For information on deploying and using Rational Reporting for Development Intelligence, see the Installing Rational Reporting for Development Intelligence page.

To get started with a new deployment of RRDI see the Getting Started page.
To upgrade an existing deployment of RRDI see the Upgrading page.

For known issues or important information about other parts of the Rational solution for Collaborative Lifecycle Management (CLM), see these pages:

Known problems and workarounds

Some prerequisite library changes on Linux

The prerequisite requirement on the openmotif library has changed. If the system which the RRDI is installed does not have the proper libXm version, the Install Manager may report an install failure like
    CogUninstall: /opt/IBM/RRDI1/cognos/uninstall/uninst not found
Please look at this tech note for more details.

WebSphere Application Server requirements

With the upgraded Cognos BI version in this RRDI release, the minimal version requirements on the WebSphere Application Server (WAS) for deploying the report server have changed since RRDI 2.0.5:

  • For WAS 7 version, WAS needs to be at version 7.0.0.29 (Fixpack 29) or above.
  • For WAS 8 version, WAS needs to be at version 8.0.0.6 (Fixpack 6) or above.
  • For WAS 8.5 version, WAS needs to be at version 8.5.0.2 (Fixpack 2) or above.
  • For WAS 8.5.5 version, WAS needs to be at version 8.5.5 without any additional Fixpack.
In all these WAS versions, the Java 6 needs to be SR5 or above.

Microsoft Internet Explorer version 10 support

If you are using Internet Explorer 10, you must enable the compatibility view when working with Rational Reporting for Development Intelligence. To enable compatibility view:

  1. Open Rational Reporting for Development Intelligence in Internet Explorer 10.
  2. If the Menu bar is hidden, press the Alt key to display it.
  3. Click Tools, Compatibility View settings.
  4. In the Add this website field, ensure that the server name for Rational Reporting for Development Intelligence is displayed.
  5. Click Add. The server name is now listed as one of the websites to open in the compatibility view.
  6. Click Close.

For a list of the known problems and workarounds, published as jazz.net workaround articles, in this release, view the Rational Reporting for Development Intelligence 2.0.6 workaround articles jazz.net query.

Downloading and unzipping the RRDI installation repositories

Download Tip: Due to the large file sizes of these downloads, we highly recommend that you use a download manager to work around a download size limitation on some web browsers (typically 2 GB maximum) and to improve the download performance.

Unzip Tip: You may experience problem to unzip the RRDI installation repositories zip files on some releases of Windows, Linux and AIX platforms. This is due to a known limitation on these platforms that prevent their "unzip" utility to unzip files bigger than 2 GBytes.

On many versions of Windows, unzipping using the default Extract All feature may even fail silently to properly unzip the files which will result in failures when installing/upgrading RRDI.

The workaround to this defect is to use a different tool to unzip the RRDI installation repositories zip files.

If you experience unzip issues on any platforms, you can use a tool like 7zip which can be downloaded from 7-zip